August 22, 2012

Maximo supported web browsers

What web browsers can be used to access Maximo?
Roughly speaking, Maximo supports only Microsoft Internet Explorer and Mozilla Firefox. Said that... I currently use Google Chrome with Maximo. Pages load faster and it works perfectly 99% of the times (except for reports).
The following table gives a quick overview of the current supported web browser versions.


Base Services version 6.2 6.2.5 7.1 7.1.1.4 7.1.1.6 7.5 7.5.0.3
Internet Explorer 6
Internet Explorer 7
Internet Explorer 8
Internet Explorer 9
Mozilla Firefox 3.0
Mozilla Firefox 3.5
Mozilla Firefox 3.6
Mozilla Firefox 4
Mozilla Firefox 10
Google Chrome

Thus we can draw the following considerations:
  • Internet Explorer 7 is currently supported by ALL versions of Maximo.
  • Firefox has a less extensive support but it generally performs better than IE.
  • Google Chrome is currently the most used web browser but it is still not supported by IBM :-(

16 comments:

  1. Strange, I actually have never had an issue using Google Chrome with Maximo, so much so that I would have thought it was supported. Thanks for this nice visual guide!

    ReplyDelete
    Replies
    1. You can't run reports with Chrome !!

      Delete
    2. You are right.
      Reports cannot be displayed with Google Chrome.
      I have updated the article to point out this issue.
      Thank you

      Delete
  2. Today, my version of Chrome was auto-updated to v25 and now Maximo list screens are not rendering correctly. Reverting back to v24 is not simple, nor is turning off auto-update for Chrome. So in addition to reports, screen rendering is broken. No easy solution for now...

    ReplyDelete
    Replies
    1. I think this only applies to Maximo 7.1. You are talking about the Maximo screen too wide? In Maximo 7.5 renders fine for me using the latest versions of Chrome, even Beta (at Chrome version 30 now).

      Delete
  3. Yeah... need fix pack for this problem...!

    ReplyDelete
  4. I just encountered the same stretching issue with Chrome v25. Not sure if it's a Chrome problem (doubtful) or an IBM problem with deprecated CSS, Java, or the like.

    ReplyDelete
  5. We encountered this bug last week, Feb. 25th, with Chrome v25. I believe it is a Chrome bug, not a deprecated CSS issue. Please see the Chrome bug report and star the issue and/or make a comment so Google will fix this.

    https://code.google.com/p/chromium/issues/detail?id=179061

    ReplyDelete
  6. As a workaround, you can use an old version of Chrome 24... I have not been able to find a Portable version yet though:

    http://www.oldapps.com/google_chrome.php?old_chrome=8686

    Old Version of Google Chrome 24.0.1312.52

    ReplyDelete
  7. Has anyone seen an issue where the primary links on the startcenter are duplicated. When you log in for the first time various links on the startcenter such as favorite applications, GoTo, StartCenter, are duplicated on the screen right next to each other. When you refresh the browser the screen returns to normal. We're on Maximo 7.1 with Firefox 10. I see now it's not supported but wasn't sure if anyone has seen this oddity before.

    ReplyDelete
    Replies
    1. Turn out it wasn't Firefox but an LDAP authentication issues related to icon displays. This includes links. Here's an IBM technote:

      http://www-01.ibm.com/support/docview.wss?uid=swg21417166

      Delete
  8. Help. I can't attach files using any web browser. I was using Firefox (not sure which version) it worked perfectly until I upgraded to 24. I have am using Windows 7 and I have been told that IE8 and 9 are not supported and can not be installed on Win7. Chrome does not work for this part. I have looked for the firefox versions mentioned but they were released in 2011 and are a security risk if you use them. Windows 7 has been out since 2009 why have IBM not sorted this by now?

    ReplyDelete
  9. Very informative and suggestive blog about Mozilla working and its related Issues ....Good Job...Congrats
    Mozilla Firefox Technical Support

    ReplyDelete
  10. Hi, please help.
    When I am using maximo (6.2.5 version) in japanese version, most of the applications are not responding properly. Using japanese is a must. I am using it in Windows 7.
    Please give me some suggestion so that I can work properly.

    ReplyDelete
    Replies
    1. This is not IBM support.
      You should open a PMR for this kind of issues.

      Delete
    2. Actually there is no support available here for maximo 6, so is there anything else you could suggest me please?

      Delete